Script Hook V

Alex9581 26112 11752 2016-10-06 в 18:49

Описание:

Script Hook V для GTA 5 — эта библиотека необходима для запуска скриптовых модификаций в GTA 5.

Что самое важное, скрипт не помешает пройти GTA 5 на 100%

На данный момент не работает в мультиплеере.

Установка:
  • 1) Поместите ScriptHook5.dll в главный каталог игры (где расположен GTA5.exe)
  • 2) Загрузку asi-скриптов осуществляет специальный загрузчик (ASI Loader), вы можете использовать любой, в том числе тот, что идет в комплекте (dinput8.dll)
  • 3) В комплекте также идет пример скрипта - NativeTrainer.asi; при необходимости также скопируйте его в "корень" игры
Что нового в обновленной версии:
  • Теперь при входе в GTA Online скриптхук закрывается, так как игра передает Rockstar список установленных модов;
  • Поддерживаются следующие патчи: 1.0.335.2, 1.0.350.1/2, 1.0.372.2, 1.0.393.2/1.0.393.4/1.0.393.4a/1.0.463.1/1.0.505.2/1.0.573.1/1.0.617.1/1.0.678.1/1.0.757.2/1.0.757.4/1.0.791.2/1.0.877.1.
Внимание! Так как Rockstar активно банит пользователей за использование модификаций и связанных с ними программ (как в одиночной игре, так и мультиплеере), настоятельно рекомендуем владельцам лицензионной копии игры перед их использованием отключаться от интернета, а также удалять модифицированные файлы из игры перед выходом в онлайн - или вовсе отказаться от использования модификаций во избежание блокировки вашей учетной записи!

Комментарии:
С сайта (20) ВКонтакте
0  
13 TOR   (2016-10-08 18:42)
Ставлю, всеравно грузит старую версию типо 791.. как же уже бесит вся эта муть со скриптами, неужели норм нельзя сделать, каждый раз одно и тоже мозгое****.

Скрипт адаптирован, бла бла бла, ставишь нифига, надо обязательно пол инета обрыть и с бубном попрыгать
0  
14 Alex9581   (2016-10-08 19:49)
Димон, я только что еще раз обновил архив, скачай, и скопируй в корень, также удали старые логи из корня. И надо учитывать, чтоб твоя учетная запись компьютера, обладала правами администратора, и рекомендую отключить родительский контроль.

И "грузить старую" - никак не может, если прошло автоматическое обновление, если у тебя не обновляется, поставь в ручную паптч http://maniamods.ru/load....-0-4405

Весь "рунет рыть" не надо, спрашивай все у нас, подскажем, поможем )
0  
15 TOR   (2016-10-08 22:19)
У меня лицуха, без скрипта пожалуйста, вперед, 887 вроде путч или каккой то, если скрипт то показывает версия 791 и вылетает... хз, может клешни у меня, но пока решил не гореть по этому вопросу.
0  
16 Alex9581   (2016-10-08 23:10)
Это очень хорошо что у тебя лицуха.
В чем тогда проблема не пойму? Скопируй в корень это, и все, затем перейди в программе на вкладку инструменты, и установи плагин опена, после этого ты сможешь редактировать игровые данные.

Или у тебя патч автоматом не обновился? Напиши подробней что не получается, не пойму тебя толком.
0  
17 TOR   (2016-10-09 09:09)
подробно, все обновился, путая гта запускается на новом патче, ставишь скрипт хук, он сразу начинает показывать что версия старая 791, и при загрузке выбивает. Скрипт хук удаляешь, игра грузится с новым патчем.. вот и все
0  
18 Alex9581   (2016-10-09 11:34)
Ну понятное дело, папку mods ты используешь?
0  
19 TOR   (2016-10-09 12:20)
аааа. кажись дошло... о я туебень crazy %)
0  
20 Alex9581   (2016-10-09 12:24)
Ага, сохрани все нужное из этой папки в удобное для тебя место, затем скопируй в папку mods обновленную папку update из корневого каталога игры.

Затем верни все модификации в новую папку mods. Удачи Дим!
0  
11 lion6   (2016-02-09 07:55)
помогите, переустановил винду 8.1, теперь не работает Script hook. до переустановки все работало.

нашел решение в инете: Ошибка «script hook v critical error. FATAL: unknown game version» чаще всего появляется после выхода новых патчей для GTA 5. Чтобы решить эту ошибку удалите все файлы статор версии плагина, а именно asiloader.log, ScriptHookV.dll, ScriptHookV.log dinput8.dll и NativeTrainer.asi, после этого установите последнюю версию плагина.
0  
12 Alex9581   (2016-02-11 07:18)
Жаль раньше не увидел твое сообщение. Да, все именно так. И кстате, это и есть последняя версия на данный момент, мы все регулярно обновляем в след за авторами.
0  
9 graf777   (2015-12-18 10:36)
А что делать с папкой SDK 1.0.393.4a и спапками внутри куда их устанавливать
0  
10 Alex9581   (2015-12-18 16:40)
Это для написания скриптов. Для игры нужен только ScriptHookV.dll и dinput8.dll из архива ScriptHookV_1.0.573.1.zip
+1  
8 portal2x2   (2015-09-17 02:21)
Спасибо.
0  
3 DEN4IK   (2015-09-16 17:39)
Чет выкидывает, по ходу папка mods не работает, придется ждать обновленные скрипты от опен4
0  
4 Veteran78   (2015-09-16 19:29)
папка модс робит у меня
0  
5 Alex9581   (2015-09-16 21:08)
Какие таки скрпты Ден? Все вышло уже, dinput8.dll это и есть обновленный скрипт, он дает возможность опену редактировать файлы в гта 5.
0  
6 DEN4IK   (2015-09-16 23:05)
Архив битый в папке модс, видать не так чет заменил или еще че
0  
7 Alex9581   (2015-09-16 23:06)
А ну ок, понял Ден.)
0  
1 Ubludock   (2015-09-15 22:39)
Исправьте описание, не "dsound.dll" а "dinput8.dll"
0  
2 Alex9581   (2015-09-15 22:52)
Ага, спасибо, исправили )
На сайт ManiaMods.ru добавлять комментарии могут только зарегистрированные пользователи.